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The information contained herein has been carefully checked and is believed to be accurate; however, no responsibility 
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notice; for up to date information please visit www.caenrfid.com. 
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 of data sheets, manuals and software. 

All you need to start using your software in a few clicks! 
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Federal Communications Commission (FCC) Notice 
 1

 

This device was tested and found to comply with the limits set forth in Part 15 of the FCC Rules. Operation is subject to 
the following conditions: (1) this device may not cause harmful interference, and (2) this device must accept any 
interference received including interference that may cause undesired operation. These limits are designed to provide 
reasonable protection against harmful interference when the equipment is operated in a commercial environment.   

This device generates, uses, and can radiate radio frequency energy. If not installed and used in accordance with the 
instruction manual, the product may cause harmful interference to radio communications. Operation of this product in 
a residential area is likely to cause harmful interference, in which case, the user is required to correct the interference 
at their own expense. The authority to operate this product is conditioned by the requirements that no modifications 
be made to the equipment unless the changes or modifications are expressly approved by CAEN RFID. 

  

 

 

                                                      
1 This declaration only applies to FCC readers A828US, A829US, A528, R1230CB, R1260I, R1260U, R4300P, A528B, R1240I, R1270, R1170I, R1250I. 
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1 GETTING STARTED 
 

 

 

 

 

Before starting: CAEN RFID reader system overview 
Before using this software it is useful to get introduced to the basic concepts of CAEN FID readers. 

A CAEN RFID reader can be seen, in a simplified model, as a box with one or more communication interfaces to the 
host side and one or more communication interfaces to the tag side. The reader receives commands coming from the 
host (a PC or any other controlling device) and it uses the interface to the tag (typically one or more antennas) to 
perform operations on tag itself and then it replies back to the host. 

 

Antennas belonging to the same reader can be grouped in logical groups called “logical sources”or simply “sources”. 

CAEN RFID protocol defines up to 4 logical sources, named from “Source_0” to “Source_3”. 

A source is composed by the 2 elements specified below: 

 Antennas:  

CAEN RFID readers can have from 1 to 4 antenna ports according to the model. In case of one antenna reader 
the only available antenna is linked to “Source_0”. In case of four antennas reader, the default configuration 
consists of a single antenna connected to a single source. Therefore “Source_0” identifies the first antenna... 
“Source_3” identifies the fourth antenna. Each antenna can be linked to the source in a non-exclusive mode: for 
example the first antenna can be linked to “Source_0” and “Source_3”. 

 A set of standard EPC Class1 Gen2 parameters:  

Q value, Session, Selected, and Target (for more info please refer to the EPC Class 1 Gen 2 specification 
document at http://www.gs1.org/gsmp/kc/epcglobal/uhfc1g2). 

 

Remember that all operations on the tags are performed through these logical sources. 

 

Installation 
CAEN RFID Easy Controller installation is provided through an auto-installer file called Setup.exe: running this, Easy 
Controller will install on pc. 

Before running, be sure that your pc meets the minimum system requirements: 

 1 gigahertz (GHz) or faster processor  

 1 gigabyte (GB) RAM 

 30 MB available hard disk space for installation (administration rights required) 

 Microsoft .NET 2.0 runtime or higher 

 Microsoft Windows XP(SP2)/Vista/7  (32 bit) 

http://www.gs1.org/gsmp/kc/epcglobal/uhfc1g2
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To install the software: 

1. Connect to our website (you need to log in or to register on our website) and download the latest version of the 
CAEN RFID Easy Controller Software. 

2. Double click on the Setup.exe and follow the instructions. 

 
 

 
 

http://www.caenrfid.com/en/CaenProd.jsp?mypage=3&parent=112&idmod=797
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If you choose default value during setup, the files of the EasyController will be placed under Program files in a folder 
named CAEN RFID Easy Controller. 
This folder contains: 
 

Directory/file name Description 

Base This directory contains information on all supported readers and on 
general options. 

BaseUtils.dll This library helps the EasyController to parse and save informations 
stored in Base folder. 

CAENRFIDLibrary.dll This is the CAEN RFID .NET library used by the Easy Controller to 
work with reader.  

Note: if you want to develop your own .NET application use the 
appropriate link to our site to download the latest version of the 
.NET library. 

Unins000.dat This file is used by the uninstaller. 

Unins000.exe This is the uninstaller: if you want to uninstall the Easy Controller 
please refer to Uninstalling CAEN RFID Easy Controller paragraph, 
pag.7. 

Easy Controller src This folder contains Visual Studio professional projects of the Easy 
controller with its source code. 

Tab. 1.1: CAEN RFID Easy Controller Directories 

 

Uninstalling CAEN RFID Easy Controller 
To uninstall CAEN RFID Easy Controller: 
 Click on Start → All Programs → CAEN RFID Easy Controller → Uninstall CAEN RFID Easy Controller. 
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2 USING CAEN RFID EASY CONTROLLER 
 

 

 

 

 

Launching CAEN RFID Easy Controller 
To launch CAEN RFID Easy Controller: 

Click on Start → All Programs → CAEN RFID Easy Controller → CAEN RFID Easy Controller. 

Or 

Click on CAEN RFID Easy Controller desktop icon (only in case Create desktop icon option was checked, during 
installation). 

 

Connect to the Reader 
Connect a CAEN RFID reader to your PC.  

Launch the CAEN RFID Easy controller application. 

On the main screen click on File → Connect. A Connection windows will open. 

Select the connection type (RS232 or Ethernet according to the reader model) and specify the serial port or network 
address (according to the selected connection type). 

 

 

 

 

 

 

 

 

 

 

Fig. 2.1: Connection port configuration 

 

In the case of the serial port connection, the textbox above it is replaced by a combobox that lists all active serial ports. 

After choosing the type of connection and the address/port, click on the Connect button to connect the reader. Any 
problem arising during the connection will be reported in the status bar located at the bottom of the window. 

Once the reader is connected, you can disconnect it by clicking on File → Disconnect. 

Note: To make sure the program runs correctly ensure that Easy controller has exclusive access to the reader. 
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Main window 
To verify if the connection with the reader is established, check the green dot down on the left side of the sidebar (see 
fig. Fig. 2.2: CAEN RFID Easy Controller Side Bar pag.9).  

Once connected to the reader, on the READER INFORMATION box you can find information on reader model, serial 
number and Firmware release. 

On the menu bar you can find four options: 

 File: contains the Connect, Disconnect, Enable Logging and Exit choices 

 Settings: contains the Source Selection and Options choices 

 Tools: contains the I/O management (GPIO) choice 

 About: opens the information dialog showing the Easy Controller Version 

 

 

Fig. 2.2: CAEN RFID Easy Controller Side Bar 

 

The Start Inventory button starts and stops the inventory process and shows the informations retrieved from the tags 
in the main window. In the TAGS FOUND text box the number of detected tags is shown. 

After the inventory has started, on the lower half of the main window you can find a table containing the following 
parameters: 

 EPC: EPC code of the inventoried tag. (tag ID)  

 L. Source: source of identification.  

 Antenna: Antenna of the source that has identified the tag.  

 TID: TID of tag, if available (default is TID reading off).  

 RSSI: Received Signal Strength Indicator (as 16 bit signed form).  

 COUNT: number of time the tag has been read  

 TimeStamp: timestamp associated with the time of first identification of tag 

 

All the above listed parameters can be displayed or not in the table. 

Using the context menu you can select the ones you want to be displayed in the table (right click with the mouse on 
the table and check/uncheck them). 
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Finally at the bottom of the main window you can find a status bar displaying the connection status (green dot = 
connected, red dot = not connected) and the anti-collision algorithm (air protocol) in use. 

During the inventory cycle you can check the following parameters inside the Statistic box: 

 Acquisitions per second (Acq/sec): the number of acquisition cycles per second.  

 Tags per second (tags/sec): the number of tags detected per second  

 Efficiency (Efficiency): is the value calculated by a Simple Moving Average algorythm using Acq/sec and tags/sec 
parameters. 

 Tot tags (Tags found): maximum number of tags detected for each inventory cycle. 

 

Information about the Easy Controller 
Information on the CAEN RFID Easy Controller are available clicking on About. 
This window shows the current revision of the .NET library used by EasyController. 
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3 QUICK START 
 

 

 

 

 

Doing inventory 
Once ensured that the reader is connected to the host (check the connection status on the status bar), the CAEN RFID 
Easy Controller allows you to control your reader. 

To start an inventory, click on Start inventory button.  

By default the reader identifies tags using Source 0 (for further information on sources see Before starting: CAEN RFID 
reader system overview pag.5). 

If you want to add sources click on Settings → Source selection and check the desired sources. 

Remember that if the reader has one antenna, only Source 0 is available. 

 

To stop the inventory click on Stop Inventory. If Enable Logging has been previously selected, then the inventory results 
are automatically logged. For logging options, see Logging options section. 

Once click on the Start Inventory button, the statistics are tabbed for source and updated values are shown only after 
about 30 total acquisitions. 

Note: the efficiency and the acquisition speed depend on several factors (antenna type, testing environment and 
parameters settings) and do not represent a reliable index for an exhaustive evaluation of the reader performance. 

 

To disable the clearing of the tags from the listview of the main window in each "Start Inventory", click right on the 
listview header and tick the menu item “clear list” (see § Fig. 3.1: Listview header pag.12). 
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Filtering Tags 
Click right on the listview header and access the “Filtering Options”: 

 

Fig. 3.1: Listview header 

 

 

Fig. 3.2: Filtering options window 

 

In the Filtering Options window, you can create filters for the inventory operations. 

To enable the filtering system, check the "Enable Filtering" on the top. 

The filters are concatenated into a unique condition linked by Boolean operators AND and OR. 

To create a new filter, click on "Add New Filter" on the right and a new line will appear in the box. 

Filter parameters: 

 Subject of the filter: 

 EPC: to filter the EPC bank of a tag 
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 TID: to filter the TID bank of a tag 

 RSSI: to filter RSSI values of a tag. 

 Condition of the filter: 

 starting with (EPC and TID): the bank starts with a specific value 

 ending with (EPC and TID): the bank ends with a specific value 

 contains (EPC and TID): the bank contains a specific value 

 not contains (EPC and TID): the bank doesn’t contain a specific value 

 Greater than (RSSI): the RSSI value is greater than a specific value. 

 Lesser than (RSSI): the RSSI value is less than a specific value. 

 Equal to: the RSSI value is equal to a specific value. 

 Values: 

 EPC and TID: hexadecimal string representing bytes (eg " 3A5F") 

 RSSI: number of a valid RSSI (eg "-421 " or -42.1 dBm). 

 Activate the filter: 

 Checked: active filter 

 Unchecked: passive filter 

 Conjunction with the next filter (only for two or more filters): 

 AND: binds the results of the current filter with the next one through the logical AND operator. 

 OR: binds the results of the current filter with the next one through the logical OR operator. 

 

To remove a filter, select the filter (check “select all” in the top of the box to remove all the filters) and click on 
“Remove Selected”. 

To confirm the created filters, click on “OK”, otherwise click on “Cancel”. 

 

Operating with tags 
After the inventory has been stopped, you can make some operations on tags that have been identified. Right click on 
the desired tag and the following context menu will appear:  

 

The available operations on tags are: 

 ProgramID 

 Read and Write 

 Lock 

 Kill 
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ProgramID 

ProgramID allows you to modify the EPC code of the selected tag. Usually EPC codes are 12 bytes length (96 bit). 

In case the EPC bank has been previously locked you will need to input an access password. 

The figure below shows the ProgramID window: 

 ID length is the number of bytes of the new ID to program: 12 bytes is the standard length 

 ID is an hexadecimal string that represents the new ID 

 Password is a hexadecimal string that represents access password; it must be exactly 4 byte long.  

 

Note: EPC Class1 Gen2 defines two types of password: “kill password” and “access password”and both are 4 byte long. 
If a tag is locked, “access password” is used for all the operations but killing: kill operation must be performed using the 
“kill password”. The two passwords are stored in a reserved bank of tag. 

For tags memory map specification, please refer to http://www.gs1.org/gsmp/kc/epcglobal/uhfc1g2 

 

Read &Write 

You can quickly read and write information inside the tag using the Read&Write command. 

The Read&Write window shows a part of the tag's memory in a mapped area. 

An example of the mapped area: 

 

 

http://www.gs1.org/gsmp/kc/epcglobal/uhfc1g2
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You can set the read/write options: 

 Memory Bank: a combobox permits to choose the memory bank (RESERVED, EPC, TID, USER) where to perform 
the read/write operation 

 Address (word): here you can specify the start address (word-oriented integer number) for the read/write 
operation 

 Length (word): (only for the read operation) here you can specify the number of words (an integer number) you 
want to read starting from Address 

 Password (Hex): here you can put the access password (hexadecimal characters) 

 

Read operation 

Refer to the precedent paragraph to set the read options (memory bank, address, length, password). 

Then click on the Read button to perform the read operation.  

A red box indicates if some parameters is wrongly read or if the tag is no more under the antenna field: 

 

To stop the reading activity in progress, press on the “Cancel” tab: 
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Write operation 

Refer to the precedent paragraph to set the write options (memory bank, address, length, password). 

You can put the value (a word) you want to write directly in the boxes of the mapped area. 

The yellow colour indicates the modified boxes: 

 

Then click on the Write button to perform the write operation.  

To stop the writing activity in progress, press on the “Cancel” tab: 
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A green box indicates that the writing operation is correctly performed and “Memory written successfully!” appears at 
the bottom of the screen: 

 

 

Instead, a red box indicates that the write operation failed and the "Fail to write some cells. Press Write to retry or 
press Read” appears at the bottom of the screen. 
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Lock 

The memory banks of the tag can be written protected by using the Lock command. 

 

The Lock window contains the following parameters: 

 Memory Bank: a combobox permits to chooce the memory bank or field (kill password field, access password 
field, EPC bank, TID bank, USER bank) where to perform the lock operation.  

 Action: it contains a list of  four lock modes available: 

- ACCESSIBLE: the bank is accessible, no need to provide password to operates on this bank 

- PERMANENT ACCESSIBLE: bank is permanent accessible, and it cannot be locked anymore 

- ACCESSIBLE ON SECURE: bank is accessible only if the password is provided 

- PERMANENT UNACCESSIBLE: bank is permanently locked, and cannot be made accessible anymore 

 Password (Hex): here you can put the access password (hexadecimal characters) 

Lock button: it performs the lock operation. An error message will appear if some parameter is wrong or the selected 
tag is no more under the antenna field. 

Note: the lock command prevents the lock and write operations on EPC, TID and USER memory bank while it prevents 
read, write and lock operations on the kill password and the access password memory fields contained in the 
RESERVED memory bank as specified by the following table Tab. 3.1: Lock – Action-field functionality pag.18. 

 

pwd-write permalock Description 

0 0 Associated memory bank is writeable from either the open or secured states. 

0 1 
Associated memeory bank is permanently writeable from either the open or 
secured states and may never be locked. 

1 0 
Associated memeory bank is writeable from the secured state but not from the 
open state. 

1 1 Associated memory bank is not writeable from any state. 

pwd-read/write permalock Description 

0 0 
Associated password location is readable and writeable from either the open or 
secured states. 

0 1 
Associated password location is permanently readable and writeable from either 
the open or secured states and may never be locked. 

1 0 
Associated password location is readable and writeable from the secured state 
but not from the open state. 

1 1 Associated password location is not readable or writeable from any state. 
Tab. 3.1: Lock – Action-field functionality 
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Kill 

You can kill a tag using the Kill command. 

Once selected Kill on the contextual menu the following Kill window will appear: 

 

This window provides a password textbox and a Kill button; type the password (4 bytes in hexadecimal format i.e. 
A013B4F9) in the textbox and press Kill. 

A dialog window will appear asking for a last confirmation. 

Warning: Be aware when a tag is killed it won't work anymore! 
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4 EASY CONTROLLER OPTIONS 
 

 

 

 

 

Options window 
On the main menu, clicking on Settings → Options, will open the Options window.  
This window has a tree-view on the left site with content in the right side.  
There are three main sections: 

 General 

 Reader Configuration 

 Logical Source Configuration 

These sections will be explained below. 
 

 
Fig. 4.1: General Options Window 
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General section 
The General section deals with identification and logging options. 

Identification 

Identification box contains inventory mode and listview options: 

 Inventory Mode. There are three inventory modes: Single, Continuous and Buffered 

- Single mode performs a single inventory cycle each time the Start Inventory button is clicked 

- Continuous mode performs continuous inventory cycles until Stop Inventory button has been clicked. 

By clicking on  button you can access the Continuos Inventory Options window.  
Select the Real Continuous Mode (RCM) to perform continuous mode, i.e., a continuous inventory via 
hardware on the source indicated by the RCM Source parameter. If this mode is disabled, the inventory is 
performed in loop via software by the Easy Controller. 
Inventory on button press can be enabled only in the readers equipped with button (for example in R1240I 
qID) and allows you to perform the inventory just by pressing the button (for more info, refer to the 
technical specifications of your reader). 

 
Fig. 4.2: Continuos Inventory Options window 

- Buffered mode takes the tags from internal buffer if available (when supported by the reader) 

 
 Note: when the Buffered mode is activated the Start Inventory button change to Download Buffer. If the 
 reader you have connected doesn't have an internal buffer, this mode is disabled. Please refer to your reader 
 documentation. 
 

 ListView Options. In this area you can operate on the following parameters: 

- Converts EPC to ASCII: converts bytes of EPC in ASCII characters. 

- Either in log?: the EPCs in the log file will show as ASCII characters too. 

- Byte Field View: this groupbox is used to choose the byte field view (useful in case of long codes). The 
hexadecimal data can be grouping in: 

   Byte: single byte 
   Word: 2 bytes 
   Dword: 4 bytes 
   Font: opens a dialog to choose the listview font. 
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Logging options 

Logging Options provides a set of preferences for the logging session: 

 Log filename: it is the file where all the logging informations will be stored: clicking on the button “...” will open 
a dialog where you can choose directory and filename. 

 Log file creation mode: here you can select between three options: 

- Overwrite: at the end of the inventory session, a log file is created overwriting the existing one. 

- Append: at the end of the inventory session, new logged data are appended at the end of the existing file. 

- New file: at the end of the inventory session, new logged data will be stored in a new file. The name of the 
file will be created with an progressive number at the end (i.e. if the name for the log file is DumpTest.txt 
and it is stored in C drive, the first log file, with absolute path, will be 'C:\DumpTest00.txt'). 

 Log Info: here you can select the parameters you want to store on the log file: 

- In the first box you can select EPC, SOURCE, ANTENNA, TID, RSSI, COUNT and TIMESTAMP. 

- In the Separator box you can choose the separation mode: Tab (Tab separated values) or CSV (comma 
separated values) useful for most spreadsheet applications. 

- In the EndLine box you can choose the endline separator: CR or CR+LF. 

- Dummy. Here you can add some extra text information in the file (i.e. a description of a reader test). 

 
If Save on Exit is checked all general settings will be saved on exit and they will be maintained for the next connection. 
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Reader configuration 
CAEN RFID Readers have some basic configuration parameters. By clicking on Reader Configuration you can access to 
the Power settings and Reader Protocol area. 
 

 
Fig. 4.3: Reader Configuration Window 

 

Power Settings Area 

 Power Input. You can increase or decrease the output power of the reader moving the slider from 0% to 100%. 
Not all values can be accepted by the reader, therefore the reader approximates the chosen value to the 
nearest valid one when releasing the mouse button from the slider. 

 In the power input box you can enable the sweep power mode. The sweeping power is useful in testing phase to 
assess the "hit rating" of a session of inventory. Specify the minimum and maximum percentage of power to be 
applied and the number of steps in which to divide the sweeping. As a result, each inventory cycle is repeated as 
many times as the steps indicated, starting from the minimum to the maximum percentage of power. 

 Power output allows you to select the measurement unit (useful in case you want information on Conducted 
Power (mW dbM) or Radiated Power (mWerp mWeirp dBmerp dBmeirp). 

 Radiated Power Parameters. In this box you can set two parameters that allow to convert the Conducted Power 
into Radiated Power (*erp and *eirp units): Antenna Gain (expressed for linear – dBi - or circular antenna type – 
dBic) and Cable Loss. 
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Reader Protocol Area 

 Change protocol to allows you to change the communication protocol. 

 
Note: in case of fixed power reader, the slider in the “Power Input” box is disabled. 
 
Note: if your reader has an integrated antenna, the Radiated Power Parameters are disabled and the values are 
automatically set with the integrated antenna values. 
 

Advanced Settings 

 

Warning: This option is for advanced users only! 

 

 
 

 RF Settings:  

  Regulation: it is not possible to modify the regulation, because the RF settings must match the 
country/region of operating to comply with local laws and regulations. The usage of the reader in 
different countries/regions from the one in which the device has been sold is not allowed. 

 Channel: modify the channel number in case of interferences. 

 Enable LBT/FHSS: by default the LBT (Listen before talk) or, depending on the regulation, the FHSS 
(frequency hopping) are enabled 

 Test: 

 Link profile: only in case of reading difficulties, you can modify the value of the link profile to increase 
the reading data rate. 
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 RF Impedance Matching:  

 SWR is the result of the impedance matching operation. 

 Matches on connect: enables the reader impedance automatch (if supported by the reader). 

 

Logical source configuration 
Logical sources concepts are described in paragraph Before starting: CAEN RFID reader system overview pag. 5 
This section is divided into two parts: 

 Source Configuration 

 Summary 

 

 
Fig. 4.4: Logical Source Configuration Window 
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Source configuration 

To configure a logical source follow the steps below: 

 Select a source from the Source Selection combobox. 

 Check/uncheck the antenna to add/remove it from the selected source.  

The status of the antenna is indicated by colour: 

- Red: bad-connected or broken antenna 

- Yellow: poor signal from antenna 

- Green: well-connected antenna 

 
Press “Refresh Antenna Status” button in case you need to check the antenna status. 
On the Properties (C1G2) area you can select some EPC parameters (Q value, Session, Selected and Target). 
For further details on these parameters, please refer to http://www.gs1.org/gsmp/kc/epcglobal/uhfc1g2. 
Click OK or Apply to change settings. 
 
Note: Q parameter is useful for the optimization of the inventory efficiency: as a rule of thumb, if you have to read a 
huge population of tags you need to select a high value for the Q parameter (7 or higher), otherwise you can select a 
lower value. 
 
Note: if your reader has one antennna connector, only Ant0 (first Antenna) and Source 0 are available.  

Summary 

Here you can find the summary of all current sources settings. 

 

http://www.gs1.org/gsmp/kc/epcglobal/uhfc1g2
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5 GPIO MANAGEMENT 
 

 

 

 

 

GPIO Management Window 
Clicking on Tools → I/O Management, the GPIO settings window will appear: 
 

 
 
This window allows you to configure up to 16 GPIO (the number of enabled GPIO depends on the reader model). 
Direction and value are represented respectively by radiobutton and checkbox (if supported by the reader). 
If the direction is set on output value, you can use the checkbox to set the output line value, if the direction is set on 
input value, the checkbox is disabled and its status reflects the input line value. 
You can also find the hexadecimal word values of current settings, useful for programmers. 
The Refresh active settings button reads and shows the current values, deleting all the non-applied changes made. 
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Multiplexer Management Window 
The Multiplexer Management Window allows you to configure up to 4 multiplexers simultaneously. 

 
Fig. 5.1: Multiplexer Management Window 

 
The GPIO to be used to drive the multiplexer are set through the parameters A0 and A1. 
If you want to disable a multiplexer on an antenna just uncheck all its RFout. 
Click “OK” to confirm, “Cancel” to cancel the latest changes. 

 

 

 

 


